Fungsi Gateway

By | September 13, 2012

Fungsi Gateway

Fungsi Gateway » Artikel Fungsi Gateway

Fungsi Gateway

Gateway adalah sebuah perangkat yang digunakan untuk menghubungkan satu jaringan komputer dengan satu atau lebih jaringan komputer yang menggunakan protokol komunikasi yang berbeda sehingga informasi dari satu jaringan computer dapat diberikan kepada jaringan komputer lain yang protokolnya berbeda.

Istilah gateway merujuk kepada hardware atau software yang menjembatani dua aplikasi atau jaringan yang tidak kompatibel, sehingga data dapat ditransfer antar komputer yang berbeda-beda. Salah satu contoh penggunaan gateway adalah pada email, sehingga pertukaran email dapat dilakukan pada sistem yang berbeda.

Fungsi Gateway

Host yang digunakan untuk mengalihkan lalu lintas jaringan dari satu jaringan ke jaringan lain, juga digunakan untuk melewatkan lalu lintas jaringan dari satu protokol ke protokol lain. Dipergunakan untuk menghubungkan dua jenis jaringan komputer yang arsitekturnya sama sekali berbeda. Jadi gateway lebih kompleks daripada bridge.

Gateway dapat diaplikasikan antara lain untuk menghubungkan IBM SNA dengan digital DNA, LAN (Local Area Network) dengan WAN (Wide Area Network). Salah satu fungsi poko gateway adalah melakukan protocol converting, agar dua arsitektur jaringan komputer yang berbeda dapat berkomunikasi.

Gateway juga bisa diartikan sebagai komputer yang memiliki minimal 2 buah network interface untuk menghubungkan 2 buah jaringan atau lebih. Di Internet suatu alamat bisa ditempuh lewat gateway-gateway yang memberikan jalan/rute ke arah mana yang harus dilalui supaya paket data sampai ke tujuan. Kebanyakan gateway menjalankan routing daemon (program yang meng-update secara dinamis tabel routing). Karena itu gateway juga biasanya berfungsi sebagai router. Gateway/router bisa berbentuk Router box seperti yang di produksi Cisco, 3COM, dll atau bisa juga berupa komputer yang menjalankan Network Operating System plus routing daemon. Misalkan PC yang dipasang Unix FreeBSD dan menjalankan program Routed atau Gated. Namun dalam pemakaian Natd, routing daemon tidak perlu dijalankan, jadi cukup dipasang gateway saja.

Cara Setting IP Address Dalam Komputer Jaringan Gateway

CaraSetting Mikrotik RouterOS PPPoE Client Sebagai Gateway Telkom Speedy.
Dengan jaringan komputer yang baik tentu jaringan internet pasti lebih kenceng.
Setup modem adsl anda sebagai bridge protocol mode.
Settingnya dapat anda temukan dari manual masing-masing modem Biasanya setting bridging protocol pada beberapa modem, ada pada menu Advance setup > WAN.
Kemudian lakukan save/reboot.
Selesai setting modem sebagai bridging (password dan user ID tidak tersimpan dimodem).
Bagi yang ingin mengganti IP address default modem bisa di konfigurasi terlebih dahulu melalui PC client.
Caranya : Masuk ke ke modem melalui browser dan masuk ke menu (biasanya) Advance Setup > LAN IP Address Contoh 192.168.1.1 lakukan save/reboot. (sekarang IP modemnya adalah 192.168.1.1) Kemudian lakukan pengubahan IP juga pada komputer client (tempat anda melakukan setup modem) menjadi (misalnya) 192.168.1.2 selesai.
Buka browser dan coba ketik IP modem (192.168.1.1 ). Berhasil?
Kita lanjut ke CPU Mikrotik RouterOS nya. Tentukan IP Address masing-masing LAN card anda.
(dibutuhkan minimal 2 LAN Card pada komputer yang akan dipasangi mikrotik) Card LAN yang akan ke modem 192.168.1.2 (PUBLIK) Card LAN yang akan dimasukkan ke hub/switch untuk jaringan lokal 192.168.10.254 (LAN).
Semua perintah yang kita ketikkan disini berbasis text (text mode) dan dilakukan di mesin mikrotiknya Agar tidak bingung, Lakukan perintah untuk memberi nama masing2 Card Ethernet tadi. Memberi nama pada masing2 Card Jaringan
>interface ethernet set ether1 name=PUBLIK
>interface ethernet set ether2 name=LAN
Setting IP Address untuk masing2 Card Lan tadi
/ip address add address=192.168.1.2/24 interface=PUBLIK
/ip address add address=192.168.10.254/24 interface=LAN
Memasukkan entry PPPoE Client. Perintah ini sudah bisa dilakukan lewat klien dan menggunakan Winbox/ gui)
/interface pppoe-client add name=pppoe-user-telkom user=telkom password=123@telkom interface=PUBLIK service-name=Internet disabled=no
(username dan password cuman perumpamaan)
Gateway — Routingnya dan masquerading
/ip route add gateway= 125.167.122.1 (IP Gateway Telkom bukan IP yang static kita) IP gateway diatas belum tentu sama, lihat terlebih dahulu ip pppoe client anda.
Jika anda belum yakin 100% ip client anda dan gateway nya, lakukan login dan dialing melalui modem anda terlebih dahulu bukan pada mode bridging seperti diatas.
Pada menu Device Info akan tampil informasi Default Gateway dan IP client pppoe anda.
Selanjutnya Masquerading, untuk penerusan perintah dari routing yang diteruskan ke NAT Firewall mikrotik untuk proses routing ke semua client yang terkoneksi
/ip firewall nat add chain=srcnat action=masquerade out-interface=internet Setting DNS dengan perintah di terminal winbox.
/ip dns set primary-dns=202.134.1.10
/ip dns set primary-dns=203.130.206.250
/ip dns allow-remote-request=yes Selesai..
tahap routing sudah terlaksanakan. Coba lakukan ping ke mikrotik dan gateway nya.
Jika anda ingin sharing ke komputer client jangan lupa masukkan ip gateway pada settingan Network Connection (windows) sesuai dengan IP LAN (192.168.10.254) pada mikrotik anda.
Banyak sekali settingan mikrotik yang dapat anda pelajari dari berbagai sumber.
Jika terkesan terlalu rumit dengan sistem pengetikan anda bisa melakukannya dengan winbox mode, setiap tutorial yang anda butuhkan pun dapat anda copy dan paste ke winbox nya mikrotik.
Setting Web Proxy Transparant /ip web-proxy set enabled=yes port=8080 hostname=dipanegara.
proxy transpa rent-proxy=yes
/ip firewall nat add in-interface=lokal dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat dst-address=!192.168.10.254/24 (portnyas bisa kita tentukan sendiri misalnya 3128 dll)
Jangan lupa untuk menset IP gateway client anda ke 192.168.10.254 agar terkoneksi ke server mikrotik
Demikian tutorial singkat jaringan komputer mikrotik sebagai gateway koneksi ke speedy dgn metode Bridging.
JIka terjadi masalah, biasanya ada pada setting gateway, untuk itu bisa dicoba menambahkan perintah pada :
/interface pppoe-client add name=pppoe-user-telkom user=telkom password=[email protected] interface=public service-name=internet disabled=no add-default-route=yes
sumber: wahyuheri.wordpress.com
Dengan cara setting jaringan komputer gateway speedy diatas bisa mempercepat kecepatan download kita
Cara setting DNS Server dalam komputer jaringan
Gateway adalah sebuah perangkat yang digunakan untuk menghubungkan satu jaringan komputer dengan satu atau lebih jaringan komputer yang menggunakan protokol komunikasi yang berbeda sehingga informasi dari satu jaringan computer dapat diberikan kepada jaringan komputer lain yang protokolnya berbeda. Definisi tersebut adalah definisi gateway yang utama.

Seiring dengan merebaknya internet, definisi gateway seringkali bergeser. Tidak jarang pula pemula menyamakan “gateway” dengan “router” yang sebetulnya tidak benar.

Kadangkala, kata “gateway” digunakan untuk mendeskripkan perangkat yang menghubungkan jaringan komputer besar dengan jaringan komputer besar lainnya. Hal ini muncul karena seringkali perbedaan protokol komunikasi dalam jaringan komputer hanya terjadi di tingkat jaringan komputer yang besar.

KEUNTUNGAN DAN KERUGIAN

MENGGUNAKAN GATEWAY PADA JARINGAN KOMPUTER

A. KEUNTUNGAN

  1. Resource Sharing, dapat menggunakan sumberdaya yang ada secara bersamasama. Misal seorang pengguna yang berada 100 km jauhnya dari suatu data, tidak mendapatkan kesulitan dalam menggunakan data tersebut, seolah-olah data tersebut berada didekatnya. Hal ini sering diartikan bahwa jaringan komputer mangatasi masalah jarak.
  2. Reliabilitas tinggi, dengan jaringan komputer kita akan mendapatkan reliabilitas yang tinggi dengan memiliki sumber-sumber alternatif persediaan. Misalnya, semua file dapat disimpan atau dicopy ke dua, tiga atu lebih komputer yang terkoneksi kejaringan. Sehingga bila salah satu mesin rusak, maka salinan dimesin yang lain bisa digunakan.
  3. Menghemat uang, Komputer berukutan kecil mempunyai rasio harga/kinerja yang lebih baik dibandingkan dengan komputer yang besar. Komputer besar seperti mainframe memiliki kecapatan kira-kira sepuluh kali lipat kecepatan komputer kecil/pribadi. Akan tetap, harga mainframe seribu kali lebih mahal dari komputer pribadi. Ketidakseimbangan rasio harga/kinerja dan kecepatan inilah membuat para perancang sistem untuk membangun sistem yang terdiri dari komputer-komputer pribadi.
  4. Hardware sharing, Bagi pakai hardware secara bersama-sama. Dengan adanyafasilitas jaringan kemudian menggunakan alat yang bernama printer server. maka sebuah printer laser berwarna yang mahal sekali harganya dapat dipakai secara bersama-sama oleh 10 orang pegawai. Begitu pula halnya dengan scanner, Plotter, dan alat-alat lainnya.
  5. Keamanan dan pengaturan data, komputer dalam sebuah lingkungan bisnis, dengan adanya jaringan tersebut memungkinkan seorang administrator untuk mengorganisasi data-data kantor yang paling penting. Dari pada setiap departemen menjadi terpisah-pisah dan data-datanya tercecer dimana-mana. Data penting tersebut dapat di manage dalam sebuah server back end untuk kemudian di replikasi atau dibackup sesuai kebijakan perusahaan. Begitu pula seorang admin akan dapat mengontrol data-data penting tersebut agar dapat diakses atau di edit oleh orang-orang yang berhak saja.
  6. Ke-stabilan dan Peningkatan performa komputasi, Dalam kondisi tertentu, sebuah jaringan dapat digunakan untuk meningkatkan performa keseluruhan dari aplikasi bisnis, dengan cara penugasan komputasi yang di distribusikan kepada beberapa komputer yang ada dalam jaringan.

B. KERUGIAN

  1. Biaya yang tinggi kemudian semakin tinggi lagi. pembangunan jaringan meliputi berbagai aspek: pembelian hardware, software, biaya untuk konsultasi perencanaan jaringan, kemudian biaya untuk jasa pembangunan jaringan itu sendiri. Infestasi yang tinggi ini tentunya untuk perusahaan yang besar dengan kebutuhan akan jaringan yang tinggi. Sedangkan untuk pengguna rumahan biaya ini relatif kecil dan dapat ditekan. Tetapi dari awal juga network harus dirancang sedemikian rupa sehingga tidak ada biaya overhead yang semakin membengkak karena misi untuk pemenuhan kebutuhan akan jaringan komputer ini.
  2. Manajemen Perangkat keras Dan Administrasi sistem : Di suatu organisasi perusahaan yang telah memiliki sistem, administrasi ini dirasakan merupakan hal yang kecil, paling tidak apabila dibandingkan dengan besarnya biaya pekerjaan dan biaya yang dikeluarkan pada tahap implementasi. Akan tetapi hal ini merupakan tahapan yang paling penting. Karena Kesalahan pada point ini dapat mengakibatkan peninjauan ulang bahkan konstruksi ulang jaringan. Manajemen pemeliharaan ini bersifat berkelanjutan dan memerlukan seorang IT profesional, yang telah mengerti benar akan tugasnya. Atau paling tidak telah mengikuti training dan pelatihan jaringan yang bersifat khusus untuk kebutuhan kantornya.
  3. Sharing file yang tidak diinginkan : With the good comes the bad, ini selalu merupakan hal yang umum berlaku (ambigu), kemudahan sharing file dalam jaringan yang ditujukan untuk dipakai oleh orang-orang tertentu, seringkali mengakibatkan bocornya sharing folder dan dapat dibaca pula oleh orang lain yang tidak berhak. Hal ini akan selalu terjadi apabila tidak diatur oleh administrator jaringan.
  4. Aplikasi virus dan metode hacking : hal-hal ini selalu menjadi momok yang menakutkan bagi semua orang, mengakibatkan network down dan berhentinya pekerjaan. Permasalahan ini bersifat klasik karena system yang direncanakan secara tidak baik. Masalah ini akan dijelaskan lebih lanjut dalam bab keamanan jaringan.

Tolong dibaca Juga yang ini.!

Welcome to my Personal Blog – Anda sedang membaca artikel tentang Fungsi Gateway dan anda bisa menemukan artikel Fungsi Gateway ini dengan kata kunci Fungsi Gateway, Anda boleh menyebar luaskannya atau mengcopy paste-nya jika artikel Fungsi Gateway ini sangat bermanfaat bagi teman-teman Anda, namun Jangan lupa untuk meletakkan link postingan tentang Fungsi Gateway sebagai sumbernya

to get more information for related topics Fungsi Gateway You can do a search in that category in the menu above, this topic is about Fungsi Gateway by isomwebs.com

Leave a Reply

Your email address will not be published. Required fields are marked *

Current ye@r *